Copying sources and texts (also in parts) for publishing without our permission is NOT ALLOWED. We are fed up with finding our work on other sites (like stackoverflow).
Das Kopieren von Quellcode und Texten (auch in Auszügen) ist nicht erlaubt. Wir haben es gründlich satt, unsere Arbeit auf anderen Webseiten zu finden.

Copying for non-public usage is allowed.           Das private Kopieren und Benutzen ist natürlich erlaubt und erwünscht.
17. Sep
Teaser

Linux: PHP 7.1 / 7.2 / 7.3 auf einem Debian 9 Server (“Stretch”) installieren

Wenn Sie auf einem Debian 9 Server (Codename “Stretch”) aktuellere Versionen von PHP (z.Bsp. PHP7.1) installieren möchten, benötigen Sie derzeit ergänzende Packetquellen.

PHP7.1 können Sie z.Bsp. auf diese Weise installieren (melden Sie sich für die Installation bitte als “root” an):

apt-get update
apt-get install ca-certificates apt-transport-https 
wget -q https://packages.sury.org/php/apt.gpg -O- | apt-key add -
echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" | tee /etc/apt/sources.list.d/php.list

Dem System wurde jetzt eine weitere Quelle für Installationspakete / Software hinzugefügt. Daher müssen die Pakete der Quellen jetzt frisch eingelesen werden:

apt-get update

Jetzt kann PHP V7.1 installiert werden:

apt-get install php7.1

Sollen weitere PHP Module gleich mit installiert werden (mySQL usw.), dann können diese in einem Rutsch installiert werden:

apt-get install php7.1 php7.1-mysql php7.1-xml php7.1-gd .... (usw.)

Möchten Sie PHP V7.2 installieren, dann ersetzen Sie die “7.1” in der vorherigen Installationszeile einfach durch “7.2”; bei PHP V7.3 bitte entsprechend.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

6 + achtzehn =